Installer Spotify sous Fedora 32 bits et 64 bits

spotify-fedora

Spotify vient d’être disponible au téléchargement en version Debian/Ubuntu en format .deb, seulement pour ceux qui utilisent Fedora (comme moi), on à besoin d’un fichier au format .rpm.

Pré-installations communes sur 32 bits et 64 bits

On instal les dépendances requisent :

A partir de Fedora 15 (32bits):

A partir de Fedora 15 (64bits):

(Merci à Erouan pour ce complément)

On installe Alien qui va permette de convertir le package Spotify en .rpm:

Installation sur 32 bits

Il faut télécharger le fichier au format .deb :

Ce rendre sur http://repository.spotify.com/pool/non-free/s/spotify/ pour télécharger le fichier se finissant en i386.deb.

Ou

Ensuite, il faut le convertir en .rpm avec Alien (installé plus haut)

Cela va vous générer le fichier spotify-client-qt-X.X.X.XXX.gccccXXX.XXX-X.i386.rpm

Il reste à installer Spotify :

Installation sur 64 bits

Il faut télécharger le fichier au format .deb :

Ce rendre sur http://repository.spotify.com/pool/non-free/s/spotify/ pour télécharger le fichier se finissant en amd64.deb.

Ou

Ensuite, il faut le convertir en .rpm avec Alien (installé plus haut)

Cela va vous générer le fichier spotify-client-qt-X.X.X.XXX.gccccXXX.XXX-X.x86_64.rpm

Il reste à installer Spotify :

Resultat

Spotify_Linux_Capture

Si ça fonctionne chez vous, laissez un petit commentaire 🙂

18 commentaires

  1. Pour ceux qui sont sous Fedora 17 ou à partir de la version 15 je crois il faut rajouter quelques liens symboliques sur différentes libs :

    – sudo ln -s /usr/lib/libssl.so.10 /usr/lib/libssl.so.0.9.8
    – sudo ln -s /usr/lib/libcrypto.so.10 /usr/lib/libcrypto.so.0.9.8
    – sudo ln -s /usr/lib/libnss3.so /usr/lib/libnss3.so.1d
    – sudo ln -s /usr/lib/libnssutil3.so /usr/lib/libnssutil3.so.1d
    – sudo ln -s /usr/lib/libsmime3.so /usr/lib/libsmime3.so.1d
    – sudo ln -s /usr/lib/libplc4.so /usr/lib/libplc4.so.0d
    – sudo ln -s /usr/lib/libnspr4.so /usr/lib/libnspr4.so.0d

    Pour la version 64 bit remplacez « lib » par « lib64 ».

  2. Ca marche nickel pour moi, mais pour la version 64 bits, il faut
    ajouter 64 des 2 côtés du lien:

    – sudo ln -s /usr/lib64/libnspr4.so /usr/lib64/libnspr4.so.0d

    etc..

  3. Bonjour,

    lorsque je souhaite lancer l’installation du .rpm, je reçois l’erreur suivante :
    error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)
    Comment puis-je corriger ça ?

    merci!

  4. J’ai réglé le problème,

    en faite il fallait remplacer tous les liens symbolique pour fedora 64
    bits.
    « sudo ln -s /usr/lib64/libssl.so.10 /usr/lib/libssl.so.0.9.8 »
    en
    « sudo ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.0.9.8 »

    Voilà, merci pour le tuto en tout cas ça fonctionne nicquel 🙂

  5. Bonjour !

    Mon installation en 32bits semble avoir bien fonctionné. Néanmoins lorsque je lance Spotify à partir du terminal, je reçois l’erreur suivante :
    spotify: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
    Qu’est-ce que ça veut dire ? comment puis-je corriger l’erreur ?
    En vous remerciant par avance !

    Amoco

  6. Je confirme qu’il faut maintenant pour la version 64bit il faut
    mettre le suffix « 64 » dans les liens symboliques.

    Petit détail aussi j’ai vu qu’il y a 3 paquets de disponible sur le
    dépôt.

    spotify-client-gnome-support_xxx.gxxx.xxx_all.deb
    spotify-client-qt_xxx.gxxx.xxx_all.deb
    spotify-client_xxx.gxxx.xxx_amd64.deb

    En tout cas le paquet « qt » n’installe plus spotify en entier. Il
    faut aussi installer le paquet spotify-client. J’ai aussi installé
    le paquet gnome-support sans problème, mais je ne sais pas ce qu’il
    apporte de plus. Surement un meilleur support de gnome ;).

  7. bonjour

    jai le meme probleme que Amoco – Le 26/10/12 à 20:11

    spotify: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

    ja fait Un petit coup de « sudo yum install libpng12.so.0

    mais moi je suis sur 64 bit..donc le probleme persiste.

    je doit faire quoi???

    merci

  8. Désormais pour fedora 17 il faut remplacer les 0.9.8 par 1.0.0. Spotify a été mis a jour apparement.

    L’installation marche mais n’est pas super stable.

    Merci pour l’aide !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *